Welcome to the GoArmyEd Assistance Center page where you can search for answers and information on GoArmyEd related topics.


GoArmyEd Assistance Center > Topics> Topic: Do I need a specifc browser to view GoArmyEd?

Do I need a specifc browser to view GoArmyEd?

Topic ID: 64096 Email Print
Question
Do I need a specifc browser to view GoArmyEd?

Answer

In order to view and complete all processes within GoArmyEd you will need to use the following browser versions or higher: Internet Explorer 11, Firefox version 38.5.2, or Google Chrome version 47. GoArmyEd will no longer be able to provide technical support for Helpdesk cases, which do not meet the minimum browser requirement. Select the link below to view the GoArmyEd recommended browser settings.

https://www.goarmyed.com/public/public_help-browser_settings.aspx

 

Need more help?

  • Select the "GoArmyEd Assistance Center" link in the left menu to return to the main page.
  • Select topics in the Related Topics section below:

Related Topics

Topic Details
Views: 3845 Created on: Apr 30, 2015
Date updated: Jan 12, 2016

Poor Outstanding